My Vista Experience, Pt. 2

Vista and current hardware should be no problem. But what about some more ancient piece of hardware?

Before installing Vista I upgraded my motherboard’s BIOS to the latest version (which by the time of writing was “F5” for my Gigabyte “GA-M55S-S3”). I think that wouldn’t have been absolutely necessary but I also hoped getting rid of my Linux “noapic-problem” – which I sadly didn’t… As already mentioned, installation of Vista was peace of cake and video, sound and ethernet worked right away. As I like to play “World of Warcraft” I did install the original vendors drivers for video, sound and chipset for better performance. No problems so far. Same goes for my Terratec Cinergy DVB-T USB stick and my HP Photosmart printer.

My MP3 player Creative Zen Xtra is a little older (I’d say about 3 years?) and believing this Creative page I just plugged it in and hoped it would work… Well, it didn’t as Vista could not find any drivers even after searching online. But why? I don’t really know, I guess it’s a firmware problem. I refused to update to the latest “PlaysForSure” firmware and stayed with version 1.20.08. So I tried the Windows XP drivers provided by Creative. To cut it short, version 1.30.03 worked whether 2.01.00 didn’t. Just install the 1.x drivers and connect your Zen Xtra to your PC. Vista will search for drivers and won’t find any, but it’ll ask if you like to specify a folder. Point to “…Program FilesCreativeJukebox 3 Drivers” and you’re set.

For my webcam Logitech provides a Vista driver here. But sadly no driver/software for my Logitech cordless mouse and “Cordless Desktop Navigator” keyboard.. 🙁 Of course both work – but just with basic functionality.

One of the first Vista updates was a driver upgrade for my Samsung SyncMaster. This messed up the color profile and all pictures would have kind of a yellow color. So I copied the file “SM205BW.icm” from Samsung’s support CD which came with the screen to a temporary folder, renamed it to “SM205BW_2.icm” (as I didn’t want to overwrite the Vista file later on) and imported the new color profile. This is done via “Advanced Display Properties”. Go to “Colormanagement”, check something like “Personal Settings for this device” (sorry, I don’t know the exact terms, as I’m running a German version of Vista), add the new colorprofile “SM205BW_2.icm” and make it default (see screenshot below). Done!

Color profile

For both, my Agfa “SnapScan 1212U” and my Canon “Powershot S40” I could not find any Vista drivers and I didn’t try the ones for Windows XP. That’s no problem because I’m using Linux as my main OS – and both work with Linux! The Agfa Scanner is really pretty old and Agfa discontinued this product line. OK, bad luck. But no drivers provided by Canon for my Powershot??? That’s very disappointing…

So, not every hardware will work with Vista. This is not Vista’s fault and hardware vendors will probably provide Vista drivers for there products in the near future – if those products are not too old… If you own some older piece of hardware, well switch to Linux 😉